جدولة المهام
توفر أداة "جدولة المهام" إمكانية أتمتة وتنفيذ مجموعة من العمليات والإجراءات بشكل تلقائي وفق تاريخ ووقت محددين مسبقاً، لضمان تنفيذ المهام في مواعيدها بدقة وانتظام.
يمكنك استخدام هذه الأداة لجدولة العديد من العمليات الدورية والمهمة، مثل إنشاء النسخ الاحتياطي للبيانات، وتدقيق الملفات، بالإضافة إلى أي إجراءات أخرى تتطلب التشغيل في أوقات محددة.
تستطيع الوصول إلى "جدولة المهام" بعد تسجيل الدخول إلى الملف، من تبويب "ملف"، فينتقل البرنامج إلى الواجهة الترحيبية التالية:

اضغط على تبويب "أدوات"، فتظهر الأدوات المتاحة للملف، ومنها أداة "جدولة المهام".

بعد الضغط على أداة "جدولة المهام"، تنبثق نافذة "المهام الحالية" كما يلي:

محتويات نافذة "المهام الحالية"
تستعرض النافذة جميع المهام الحالية التي تم إضافتها إلى الملف الحال، مع إمكانية إضافة مهام جديدة، أو التعديل على المهام السابقة وحذفها، فتحتوي النافذة على ما يلي:
جدول المهام المجدولة
يعرض الجدول جميع المهام الجديدة التي تضفيها باستخدام زر "جديد"، بحيث تظهر تفاصيل المهام ضمن الأعمدة التالية:
-
المهمة (اسم المهمة)
-
الجدولة (تاريخ ووقت تنفيذ المهمة المجدولة)
-
حالة آخر عملية (لم تنفذ، نجاح)
سجل التنفيذ
توفر لك النافذة إمكانية استعراض سجل المهام التي تم تنفيذها، فبعد الضغط على زر "سجل التنفيذ"، ينتقل البرنامج إلى تقرير "سجل التنفيذ" الذي يحتوي على بيانات المهام المجدولة المنفّذة من حيث: التاريخ، الاسم، الحالة، الوقت.
زر جديد
يستخدم لإضافة مهمة مجدولة جديدة إلى الملف، فبعد الضغط على زر "جديد"، تنبثق نافذة "المهمة المجدولة" كما يلي:

سيتم شرح النافذة وآلية استخدامها لإضافة مهمة جديدة في فقرة "جدولة مهمة جديدة أدناه.
زر تعديل
يمكنك تعديل المهام المُضافة مسبقاً، فبعد الضغط على المهمة المطلوبة من جدول المهام، اضغط على زر "تعديل"، فتنبثق نافذة "المهمة المجدولة" للتعديل على حقول المهمة، أو تغيير أوقات الجدولة.
زر حذف
يستخدم لحذف المهمات المُضافة مسبقاً، فبعد الضغط على المهمة ضمن جدول المهام، اضغط على زر "حذف"، فتنبثق رسالة تحذيرية للتأكد من أنك تريد حذف المهمة، اضغط على زر "حذف" من الرسالة للمتابعة وحذف المهمة، أو اضغط على زر "إلغاء الأمر" للتراجع عن حذف المهمة.
زر تحديث
يستخدم في حالة جدولة مهمة جديدة، بحيث يتم تحديث النافذة، وإضافة المهمات غير المدرجة إلى جدول المهام المجدولة.
زر إغلاق
اضغط على الزر لإغلاق نافذة "المهام الحالية".
جدولة مهمة جديدة
تستطيع البدء في جدولة المهمة بالضغط على زر "جديد" في نافذة "المهام الحالية"، فتنبثق نافذة "المهمة المجدولة"، كما يلي:

تحتوي نافذة "المهمة المجدولة" على الحقول والخيارات اللازمة لإضافة مهمة مجدولة جديدة، وهي كالآتي:
اسم المهمة
أدخل اسم المهمة المجدولة التي تُضيفها، وهو حقل إجباري.
جدول الصيانات المجدولة
يعرض الجدول الصيانة التي ستنفذها المهمة، بحيث يمكنك اختيار أكثر من صيانة واحدة لإدراجها ضمن المهمة المجدولة،
تستطيع اختيار الصيانة من نافذة "المهام المجدولة" التي تنبثق عن زر "جديد" المتوفر تحت جدول الصيانات المجدولة مباشرة.
بعد اختيار الصيانة، تندرج ضمن الجدول، ويظهر بجوارها خانة تحديد مفعّلة تلقائيّاً، وتعني بأن عملية الصيانة ستتوقف عند الفشل.

جديد
يستخدم لإضافة الصيانة إلى جدول الصيانات المجدولة، وهي المهمة التي تريد جدولتها، فبعد الضغط على زر "جديد"، تنبثق نافذة "المهام المجدولة"، كما يلي:

تحتوي النافذة على قائمة بالمهام المتوفرة التي يمكنك جدولتها، وبعد الضغط على إحدى المهام، تظهر نافذة الصيانة الخاصة بالمهمة لضبط الخيارات المناسبة، وهي كالآتي:
- نسخ احتياطي

- تدقيق أرصدة المواد والأسعار

- حساب الوسطي المرجح الثابت

-
تدقيق أرصدة الحسابات
-
تقليص حجم قاعدة البيانات

-
فهرسة الملفات
-
إعادة تسعير الفواتير وتوليد قيودها

- إعادة تسعير فواتير عمليات التصنيع

- إعادة توليد فواتير عمليات التصنيع

- إعادة توليد سندات القيد

- توليد سندات القيد وترحيل الفواتير

- ترحيل سندات القيد

- تفريغ الجداول التي تحوي نتائج مؤقتة

- تدقيق الملفات

- إعادة توليد قيود الكلفة

جميع النوافذ السابقة التي تظهر بعد اختيار المهمة المناسبة، جميعها تحتوي على الأزرار التالية:
-
إنهاء: لإدراج المهمة ضمن جدول الصيانات المجدولة.
-
السابق: للعودة إلى نافذة "المهام المجدولة".
-
إلغاء الأمر: للتراجع وإغلاق النافذة.
بعد الضغط على زر "إنهاء" تظهر المهمة في جدول الصيانات المجدولة ضمن نافذة "المهمة المجدولة"، بحيث يمكنك تعيين الوقت المناسب لتنفيذها من النافذة التي تنبثق عن زر "جدولة" المتوفر أيضاً في نافذة "المهمة المجدولة"، ثم اضغط على زر "موافق"، لحفظها، وإضافتها إلى جدول المهام المجدولة ضمن نافذة "المهام الحالية"، ليتم تنفيذها بالوقت المناسب.
تعديل
يمكنك تعديل الصيانات المُضافة مسبقاً، فبعد الضغط على الصيانة المطلوبة من جدول الصيانات المجدولة، اضغط على زر "تعديل"، فتنبثق نافذة المهمة للتعديل على خياراتها وحقولها.
حذف
يستخدم لحذف الصيانات المُضافة مسبقاً، فبعد الضغط على الصيانة ضمن جدول الصيانات المجدولة، اضغط على زر "حذف"، فتُحذف من الجدول مباشرة.
جدولة
يستخدم زر "جدولة" لضبط خيارات الجدولة، فبعد الضغط عليه، تنبثق نافذة "جدولة المهام"، كما يلي:

تحتوي النافذة على عدد من الخيارات لضبط تاريخ وتوقيت تنفيذ المهمة، وتستخدم بالشكل التالي:
نوع الجدولة
اختر نوع الجدولة الذي يتناسب مع طبيعة المهمة وهدفك منها، بحيث ينسدل من الحقل الخيارات التالية:
-
يومي
-
أسبوعي
-
شهري
في اليوم
يُتاح الحقل عندما يكون نوع الجدولة "شهري"، ويستخدم لإدخال رقم اليوم المطلوب من الشهر لتنفيذ المهمة فيه، مثلاً، أدخل رقم "1"، ليتم تنفيذ المهمة في اليوم الأول من كل شهر (وفقاً لنطاق التاريخ الذي تحدّده في الحقول: اعتباراً من تاريخ، حتى تاريخ).
في يوم
يُتاح الحقل عندما يكون نوع الجدولة أسبوعي، ويستخدم لاختيار يوم الأسبوع الذي تريد تنفيذ المهمة فيه، بحيث ينسدل من الحقل قائمة بجميع أيام الأسبوع.
خيارات التكرار
توفر لك النافذة إمكانية تحديد عدد مرات تكرار تنفيذ المهمة في اليوم الواحد، وذلك بتفعيل الخيار المناسب مما يلي:
-
مرة واحدة (الخيار المفعّل افتراضيّاً).
-
تتكرر كل، فعّل الخيار، ثم أدخل عدد الساعات التي تريد تكرار تنفيذ المهمة بعد مرورها.
حقول التوقيت
تتيح لك النافذة إمكانية تحديد توقيت تنفيذ المهمة بالتفصيل، بحيث توفر الحقول التالية:
-
ساعة
-
دقيقة
-
ثانية
-
الفترة (صباحي، مسائي)
حقول نطاق التاريخ
عيّن النطاق الزمني لكي يتم تكرار تنفيذ المهمة وفقاً له، وذلك باستخدام الحقول التالية:
-
اعتباراً من تاريخ: أدخل التاريخ الي يبدأ به تنفيذ المهمة.
-
حتى تاريخ: أدخل التاريخ الذي ينتهي به تنفيذ المهمة.
اضغط على زر "موافق" لحفظ جدولة المهمة.
اضغط على زر "إلغاء الأمر" للتراجع وإغلاق النافذة.
موافق
اضغط على زر "موافق"، بعد إضافة الصيانات التي تريد تنفيذها في المهمة الحالية، لحفظها والبدء في تنفيذها وفقاً لخيارات الجدولة.
إلغاء الأمر
اضغط على زر "إلغاء الأمر" للتراجع عن إضافة الصيانات (المهام) وإغلاق نافذة "المهمة المجدولة.
تأكد من أن SQL Server Agent في وضعية العمل، ليتم تنفيذ المهام.
لإضافة مهمة مجدولة جديدة، اتّبع الخطوات التالية:
-
اتّجه إلى تبويب "ملف" من الشريط الرئيسي للبرنامج، بعد تسجيل الدخول إلى الملف.
-
اضغط على تبويب "أدوات"
-
اضغط على أداة "جدولة المهام".
-
اضغط على زر "جديد" من نافذة "المهام الحالية" المنبثقة.
-
اضغط على زر "جديد" من نافذة "المهمة المجدولة".
-
اختر المهمة (الصيانة) المطلوبة، ثم من نافذة الصيانة -بعد ضبط الخيارات المناسبة- اضغط على زر "إنهاء"
-
اضغط على زر "جدولة" من نافذة "المهمة المجدولة"
-
اضبط خيارات الجدولة المناسبة، ثم اضغط على زر "موافق" من نافذة "جدولة المهام
-
اضغط على زر "موافق" في نافذة "المهمة المجدولة
وبذلك تم إضافة مهمة مجدولة جديدة